Admin Portal Issues
Resolved
We have resolved the issue some customers had accessing their online account at admin.vonage.com. If you are still having an issue, please contact our support teams at 1-866-901-0242.
Posted Apr 11, 2022 - 17:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 11, 2022 - 15:17 UTC
Monitoring
The issue has been resolved for some Vonage Business customers. Please try again as you may no longer be impacted.
Posted Apr 11, 2022 - 15:17 UTC
Investigating
Some Vonage Business customers may be experiencing issues accessing their online account at app.vonage.com. Our engineers are working to quickly resolve the issue.
Posted Apr 11, 2022 - 14:32 UTC
This incident affected: Online Account (Admin User Interface).