World office Singapore in country OB call completion issue
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 18:14 UTC
Monitoring
Service is now recovered by the carrier and we are monitoring. If you are still experiencing issues please contact support.
Posted Jan 18, 2024 - 18:03 UTC
Identified
We are working with our carrier for resolution
Posted Jan 18, 2024 - 17:28 UTC
Investigating
The World Office Singapore customers are experiencing OB call completion issue to the local SG numbers
Posted Jan 18, 2024 - 17:28 UTC
This incident affected: Voice Services (Outbound Call Completion).