Contacts & Call Dashboard not loading in Desktop app

Resolved

We have resolved the intermittent issues with loading contacts in the call dashboard and desktop app. If you are still having an issue, please contact us.
Posted Aug 01, 2025 - 00:40 UTC

Monitoring

The issue has been resolved for some Vonage Business customers. Please try your call again as your issue may be resolved.
Posted Jul 31, 2025 - 20:17 UTC

Investigating

We are currently investigating an issue where some customer's contacts and call dashboard in the desktop app are not loading. Our engineers are working to quickly resolve the issue.
Posted Jul 31, 2025 - 19:38 UTC
This incident affected: Applications (Desktop App).