Admin Portal - Unable to Add or Edit e911 Locations
Resolved
The issue with adding and editing e911 locations has been resolved. If you are still having an issue, please contact us.
Posted Jan 17, 2024 - 22:39 UTC
Monitoring
Our vendor has completed emergency maintenance. Users are now able to add and edit e911 locations.
Posted Jan 17, 2024 - 22:14 UTC
Investigating
We have identified an issue with a third-party vendor which is preventing users from adding and updating e911 locations in the Admin Portal. Our engineers are working to quickly resolve the issue.
Posted Jan 17, 2024 - 22:05 UTC
This incident affected: Admin Portal.