Performance and accessibility issues with admin.vonage.com, Vonage Integration Suite, and Mobile/Desktop Applications

Resolved

We have resolved the performance and accessibility issues some customers were experiencing. If you are still having an issue, please contact us.
Posted Jul 18, 2023 - 18:44 UTC

Monitoring

Our engineering teams have observed performance improvements and recovery for some Vonage Business customers. Vonage will continue to monitor to ensure there is stability.
Posted Jul 13, 2023 - 14:59 UTC

Identified

Our engineering teams have observed performance improvements and recovery for some Vonage Business customers. Vonage will continue to investigate and mitigate to ensure there is stability.
Posted Jul 12, 2023 - 23:30 UTC

Monitoring

Our engineering teams have observed performance improvements and recovery for some Vonage Business customers. Vonage will continue to investigate and mitigate to ensure there is stability.
Posted Jul 12, 2023 - 23:23 UTC

Update

We are continuing to investigate this issue.
Posted Jul 12, 2023 - 19:36 UTC

Update

Our engineers and support teams are dedicated to resolving this as soon as possible. Please stay tuned for further updates.
Posted Jul 12, 2023 - 19:02 UTC

Update

We are continuing to investigate this issue.
Posted Jul 12, 2023 - 16:37 UTC

Update

We are continuing to investigate this issue.
Posted Jul 12, 2023 - 16:04 UTC

Update

We are continuing to investigate the issue. Users are able to login to admin.vonage.com, but may experience some slowness in the portal.
Posted Jul 12, 2023 - 15:03 UTC

Investigating

We are currently investigating the issue.
Posted Jul 12, 2023 - 14:45 UTC
This incident affected: Admin Portal, Integrations (Vonage Integration Suite), and Applications (Desktop App, Mobile App (Android™), Mobile App (iOS)).