Inbound call completion to some World office numbers
Resolved
We have resolved the intermittent issue some customers had receiving world office calls. If you are still having an issue, please contact us.
Posted Feb 11, 2022 - 15:56 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 11, 2022 - 14:24 UTC
Monitoring
Service is now recovered and we are monitoring. If you are still experiencing issues please contact support.
Posted Feb 11, 2022 - 14:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 11, 2022 - 14:05 UTC
Investigating
Some Vonage Business customers may be experiencing intermittent issues receiving calls for their world office numbers. Our engineers are working to quickly resolve the issue.
Posted Feb 11, 2022 - 14:05 UTC
This incident affected: Voice Services (Inbound Call Completion).