Call Queue Impairment
Resolved
This incident has been resolved.
Posted May 17, 2022 - 18:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 17, 2022 - 18:28 UTC
Investigating
Some Vonage Business customers may be experiencing an issue with the Call Queue feature. Our engineers are working to quickly resolve the issue.
Posted May 17, 2022 - 16:55 UTC
This incident affected: Features (Feature).