Partial Inbound Call Completion Issues

Resolved

We have resolved the intermittent issue some customers had receiving calls. If you are still having an issue, please contact our support teams at 1-866-901-0242.
Posted Jun 11, 2025 - 20:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 19:55 UTC

Investigating

Some Vonage Business customers may be experiencing intermittent issues receiving calls. Our engineers are working to quickly resolve the issue.
Posted Jun 11, 2025 - 19:40 UTC
This incident affected: Features (Virtual Receptionist).